База знаний
В чем суть несовместимости с шлюзом Kerio Control версии ниже 8.2
Опубликовано on 23 June 2015 13:45

В чем суть несовместимости вашего ПО с шлюзом Kerio Control версии ниже 8.2.

В предыдущих версиях реализации Kerio Control  (ранее назывался Kerio WinRoute Firewall и WinRoute Pro) наблюдалась ошибка с поддержкой команды OPTIONS). Проблема с поддержкой этой команды решена в версии 8.2 и выше, что подтверждает сам производитель http://www.kerio.com/kerio-control-release-history-older-releases
В случае использования версии Kerio Control ниже 8.2 мы рекомендуем обновить программное обеспечение для прокси до актуальной версии.

Для работы вашего ПО действительно нужна поддержка http/OPTIONS?

Да, поддержка OPTIONS требуется. 
Сервис использует CORS(Cross-origin resource sharing), для чего браузер обязан посылать OPTIONS-запрос для подтверждения прав одного домена отправлять запросы на другой.

 

 

(5 голос(а))
Эта статья помогла
Эта статья не помогла

Комментарии (0)
Добавить новый комментарий
 
 
Полное имя:
Email:
Комментарии:
Проверка CAPTCHA 
 
Пожалуйста, введите текст с картинки, расположенной ниже. Это необходимо для предотвращения автоматической регистрации и отправки данных через форму.